Thank you so much for your involvement with the Owner's Club Forum! We hope you've gotten some great information and had the chance to interact with other owners on the current system.

We are excited to announce that a full Forum system upgrade is under way, which will make it even easier to get answers to your questions, help other owners by using your boating experience, and receive dependable advice from our network of experts. While things may look and operate a little differently, we believe the new system will ultimately improve your Forum Member experience.

We are doing everything we can to transition your account smoothly without you having to change your current login, username or password. You should be able to get into your account exactly the same way once the transition takes place. However, if you have any questions or comments, please leave a comment in the General Discussions category.

We look forward to sharing new features with you as we upgrade and improve your Owner's Club Forum experience!

I need help diagnosing 2001 San Pan Ignition switch / kill switch problem

RoqetmanRoqetman Posts: 2Member
I took my San Pan out yesterday.  It cranked up perfectly at the dock. It has 100hp Yamaha 4 stroke engine with trim switch button on the throttle.  I got out on the lake and switched it off.  When I tried to restart it the engine would not turn over, it would just click.  I also noticed the trim switch would not work.  The trim normally works whether the switch is on or off but it was dead too.  All other accessories worked, just would not restart.  I got towed back to the dock put a battery charger on it for an hour, still nothing.  The battery is 1 year old and as I said it started perfectly when I first got to the dock.  I checked all the fuse reset buttons.  I figure it could be a bad ignition switch or kill switch but... Why is the trim switch also not working.  Any advice is greatly appreciated.  Thanks!

Comments

Sign In or Register to comment.