Thank you so much for your involvement with the Owner's Club Forum! We hope you've gotten some great information and had the chance to interact with other owners on the current system.

We are excited to announce that a full Forum system upgrade is under way, which will make it even easier to get answers to your questions, help other owners by using your boating experience, and receive dependable advice from our network of experts. While things may look and operate a little differently, we believe the new system will ultimately improve your Forum Member experience.

We are doing everything we can to transition your account smoothly without you having to change your current login, username or password. You should be able to get into your account exactly the same way once the transition takes place. However, if you have any questions or comments, please leave a comment in the General Discussions category.

We look forward to sharing new features with you as we upgrade and improve your Owner's Club Forum experience!

live well

danodano Posts: 1Member
just put my new boat in the water turned on the live well and no water I opened the water inlet in the tank per the owner manual am I miss something. has anyone else had this problem  thank you for the help

Comments

  • DdancersDdancers Posts: 134Member ✭✭
    I have two live wells both fill at same time when I turn on switch. Maybe you have obstruction at pump. Can you hear pump running? If not try pushing reset on trip button under switch.
Sign In or Register to comment.