Thank you so much for your involvement with the Owner's Club Forum! We hope you've gotten some great information and had the chance to interact with other owners on the current system.

We are excited to announce that a full Forum system upgrade is under way, which will make it even easier to get answers to your questions, help other owners by using your boating experience, and receive dependable advice from our network of experts. While things may look and operate a little differently, we believe the new system will ultimately improve your Forum Member experience.

We are doing everything we can to transition your account smoothly without you having to change your current login, username or password. You should be able to get into your account exactly the same way once the transition takes place. However, if you have any questions or comments, please leave a comment in the General Discussions category.

We look forward to sharing new features with you as we upgrade and improve your Owner's Club Forum experience!

Water in transom Motor Mount

I have a 2013 Sweetwater 18 foot fish model with a 40hp Merc, the motor mount area fills up with water and the engine is covered in water splash at about 3500 rpm.  It helps a little when I trim up the engine, but still a lot of water splash on the engine.
Could this be a prop issue or is the motor mounted too low?
Thanks
·

Comments

  • Capt_SteveCapt_Steve Posts: 165Member admin
    @fishbyte ... not wanting to pass the buck on this, but your dealer should check this out on a brand new boat. I'd hate to suggest something that leads everyone in the wrong direction. Let us know what you find out. 
    ·
  • RickFisherRickFisher Posts: 14Member
    My 2013 Aqua Patio 220 DF has similar.  Water in the transom seems to drain out underway, but the splash is unacceptable.  I have a date set to have the dealer look at it.  Worse than the splash is that the fuel line, and the primer bulb, are underwater when the boat is at rest.  I think that's real bad.  Good luck on fixing your splash.
    ·
  • Capt_SteveCapt_Steve Posts: 165Member admin
    @fishbyte @RickFisher ... I've sent this thread along to customer support and will post the response.
    ·
  • fishbytefishbyte Posts: 2Member

    Finally got the dealer to look at the issue, after they talked with the factory, they said to raise the motor one hole and add a deflector to the engine mount.

    The dealer did raise the motor and it does help, but still waiting on the deflector to see if this helps with all the water in the engine pod.

    I had the issue with the fuel line also, so I added a zip tie to it so it was not under water.

    Not impressed with the design of this pontoon or the response I am getting for correcting the issues, still waiting and the Summer is half over.

    Capt Steve, can you tell me how fast this boat should go with the 40hp Bigfoot on it?

     

     

    ·
  • RickFisherRickFisher Posts: 14Member
    Totally satisfied with what they did with the fuel line.  They changed the direction fuel leaves the spin on filter.  It exits towards the front, and they mounted the primer bulb high and dry on the forward wall of the transom pan.  A very good fix.  I get less splash.  I suspect they raised the motor, but haven't confirmed.  The kid who delivered the boat back to me was not one who worked on it.  

    Cap'n Rick
    ·
  • Capt_SteveCapt_Steve Posts: 165Member admin
    @fishbyte ... I don't have performance numbers on your specific boat/motor combination, but I suspect you're looking at high teens for MPH unless you have it loaded up. 

    Awaiting a response to make sure your deflector has been shipped.
    ·
  • KoerbKoerb Posts: 9Member
    Owner of a 2013 240 Aqua Patio,  I'm also having the same problems that RickFisher is having.   Are the engine mounted deflectors a standard item which was missed on my model or are they something that has been added to the 2014 models seeing all the negative feedback?   Can I get information on these deflectors as my motor well is consistently filled with water.  Thank you for any assistance in this mater.

    John Koerber 
    ·
  • Capt_SteveCapt_Steve Posts: 165Member admin
    @Koerb ... yes, you should be able to get a set. Your dealer can order for you and install.
    ·
  • KoerbKoerb Posts: 9Member
    Does anyone have a picture(s) of these deflector's installed so I have some idea what I'm talking about when I go to my dealership?  Thanks

    John Koerber
    ·
  • Capt_SteveCapt_Steve Posts: 165Member admin
    @Koerb...please contact Matt at mstewart@nauticglobalgroup.com for a pic
    ·
  • RickFisherRickFisher Posts: 14Member
    Dealer told me there was nothing he can do on the splash.  Cap'n Steve.... I'd like to more about that add on deflector.  Apparently my dealer has not heard of it.  He says the boat is as Godfrey designed it.  
    ·
  • Capt_SteveCapt_Steve Posts: 165Member admin
    Hey Rick...did you ever hear back from Matt at Godfrey? He's very knowledgable about this program, and can tell you more details about a deflector. Just give him a shout, and he will be glad to put this in motion for you. Thanks, Steve

    Matt can be reached at mstewart@nauticglobalgroup.com
    ·
  • RickFisherRickFisher Posts: 14Member
    Reply came from Lisa Boyer.  She sent me a photo.  I have the deflector.  Marina doesn't want to raise the engine, but I may insist.  Really think the splash is excess.  Shouldn't have water landing on the fishing chairs.  
    ·
Sign In or Register to comment.